aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2018-01-25 19:47:28 +0100
committerNeels Hofmeyr <neels@hofmeyr.de>2018-02-27 22:27:51 +0100
commitf7607d63290583f978e6c6677694047d823b8f05 (patch)
tree9104be3f220b4276e3d058081d2830e8f332b8be /tests/Makefile.am
parent011a0b4d066ef1abe1adde029cf8e8a9759dbc78 (diff)
TBF: override send function via linker option
Use --wrap linker facility to override pcu_sock_send() similar to other Osmo* projects. Change-Id: Ia3d436bd3d1fb0ce8e98526bd7457f4c57667ceb
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 1595a07e..e82647f1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -33,6 +33,7 @@ tbf_TbfTest_LDADD = \
$(LIBOSMOGSM_LIBS) \
$(LIBOSMOCORE_LIBS) \
$(COMMON_LA)
+tbf_TbfTest_LDFLAGS = -Wl,--wrap=pcu_sock_send
bitcomp_BitcompTest_SOURCES = bitcomp/BitcompTest.cpp ../src/egprs_rlc_compression.cpp
bitcomp_BitcompTest_LDADD = \