aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorIvan Kluchnikov <kluchnikovi@gmail.com>2012-07-12 14:49:15 +0400
committerIvan Kluchnikov <kluchnikovi@gmail.com>2012-07-12 14:49:15 +0400
commitef7f28cc7fe67e353821c5f88bc80d5120fec3ca (patch)
treeca1b24fafa82862b1d5cd38ce1434973033588f0 /src/Makefile.am
parentc7e7f6868b6f24346424dee904f4e76d3f216ff4 (diff)
parente13fa2d56936d6bed8febcc41508a30e4a1038f0 (diff)
Merge branch 'jolly_new'
Merge is based on jolly_new branch with two modifications. 1. Modified PCU L1 interface. pcu_l1_if.cpp - common functions for tx and rx messages on L1 interface. sysmo_sock.cpp - SYSMO-PCU socket functions. openbts_sock.cpp - OpenBTS-PCU socket functions. pcuif_proto.h - L1 interface's primitives. 2. Modified encoding of RLC/MAC Control messages, now we use structures and encode_gsm_rlcmac_downlink() function for encode control blocks (without hand-coding).
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b7b9885a..ca586fda 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,12 +18,8 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# FIXME: This has to go!!
-OPENBSC_DIR = $(top_srcdir)/../openbsc/openbsc
-OPENGGSN_DIR = $(top_srcdir)/../openggsn
-
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) -I$(OPENBSC_DIR)/include
-AM_CXXFLAGS = -Wall -ldl -pthread -lgtp
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES)
+AM_CXXFLAGS = -Wall -ldl -pthread
noinst_LTLIBRARIES = libgprs.la
@@ -33,15 +29,18 @@ libgprs_la_SOURCES = \
gsm_rlcmac.cpp \
gprs_bssgp_pcu.cpp \
gprs_rlcmac.cpp \
+ gprs_rlcmac_data.cpp \
+ gprs_rlcmac_sched.cpp \
gsm_timer.cpp \
- bitvector.cpp
+ bitvector.cpp \
+ pcu_l1_if.cpp
if ENABLE_SYSMOBTS
libgprs_la_SOURCES += \
- sysmo_l1_if.cpp
+ sysmo_sock.cpp
else
libgprs_la_SOURCES += \
- pcu_l1_if.cpp
+ openbts_sock.cpp
endif
noinst_PROGRAMS = \
@@ -54,6 +53,7 @@ noinst_HEADERS = \
gsm_rlcmac.h \
gprs_bssgp_pcu.h \
gprs_rlcmac.h \
+ pcuif_proto.h \
pcu_l1_if.h \
gsm_timer.h \
bitvector.h