aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-06-18 12:21:03 +0800
committerAndreas Eversberg <jolly@eversberg.eu>2012-07-06 07:24:41 +0200
commitd679009a2dbe88869d699060bac40139d79cbd23 (patch)
tree489102a35f425a2c2853525e367d3f05ecf39ef3 /src/Makefile.am
parente6228b34a75efcb6b0700ac29672d62539860fbf (diff)
remove dependencies to openbsc/osmoggsn internals
...and link against libosmogb (part of libosmocore.git)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 3 insertions, 18 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4f8a548c..78c01e1d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,12 +18,8 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# FIXME: This has to go!!
-OPENBSC_DIR = $(top_srcdir)/../openbsc/openbsc
-OPENGGSN_DIR = $(top_srcdir)/../openggsn
-
-AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) -I$(OPENBSC_DIR)/include
-AM_CXXFLAGS = -Wall -ldl -pthread -lgtp
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES)
+AM_CXXFLAGS = -Wall -ldl -pthread
noinst_LTLIBRARIES = libgprs.la
@@ -69,18 +65,7 @@ RLCMACTest_LDADD = \
pcu_SOURCES = pcu_main.cpp
pcu_LDADD = \
libgprs.la \
- $(OPENBSC_DIR)/src/libgb/gprs_ns.o \
- $(OPENBSC_DIR)/src/libgb/gprs_bssgp.o \
- $(OPENBSC_DIR)/src/libgb/gprs_bssgp_bss.o \
- $(OPENBSC_DIR)/src/libgb/gprs_bssgp_util.o \
- $(OPENBSC_DIR)/src/libgb/gprs_ns_frgre.o \
- $(OPENBSC_DIR)/src/libcommon/socket.o \
- $(OPENBSC_DIR)/src/gprs/gprs_llc.o \
- $(OPENBSC_DIR)/src/gprs/gprs_gmm.o \
- $(OPENBSC_DIR)/src/gprs/gprs_sgsn.o \
- $(OPENBSC_DIR)/src/gprs/sgsn_libgtp.o \
- $(OPENBSC_DIR)/src/gprs/gprs_sndcp.o \
- $(OPENBSC_DIR)/src/gprs/crc24.o \
+ $(LIBOSMOGB_LIBS) \
$(LIBOSMOCORE_LIBS) \
$(LIBOSMOGSM_LIBS) \
$(COMMON_LA)