aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg <jolly@eversberg.eu>2012-06-23 10:33:16 +0200
committerAndreas Eversberg <jolly@eversberg.eu>2012-06-23 10:33:16 +0200
commit0aed654ac735749be31e4119336808596136aac3 (patch)
tree3c43968af08245576fa42198814347700dd978b8 /src/Makefile.am
parentf6b7ca5dd4ba93c13307313c61f06509645b6bca (diff)
Split of L1 interface to be used with OpenBTS or sysmo-BTS
The OpenBTS socket functions are moved from main to pcu_l1_if.cpp. New sysmo_l1_if.cpp is introduced. It used special unix socket interface to connect to sysmo-BTS. This is required to access CCCH/RACH and info about cell layout. Traffic is also forwarded via this interface, but it direct access of L1 baseband DSP will be added soon. In order to handle ready-to-send requests above l1_if, the transmit queue (for downlink blocks) is moved to gprs_rlcmac.cpp. The TBF instance additionally holds TRX and TS info, but this is only a hack currently. TBF instance requires more details about allocated ressources in the future.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1728c9e8..db1f87f9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -33,10 +33,17 @@ libgprs_la_SOURCES = \
gsm_rlcmac.cpp \
gprs_bssgp_pcu.cpp \
gprs_rlcmac.cpp \
- pcu_l1_if.cpp \
gsm_timer.cpp \
bitvector.cpp
+if ENABLE_SYSMOBTS
+libgprs_la_SOURCES += \
+ sysmo_l1_if.cpp
+else
+libgprs_la_SOURCES += \
+ pcu_l1_if.cpp
+endif
+
noinst_PROGRAMS = \
RLCMACTest \
pcu