aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-10-26 17:32:04 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-10-30 21:24:11 +0100
commitd11290b90bb5f32a7d57affbe11bdadb24e42db0 (patch)
treeaad9260528d069fab731ec88b59c49b96e15913d /src/Makefile.am
parent6f9f434463d6ba0d195f0b36cd67b57e24b1c7e9 (diff)
pdch/tbf: Move gprs_rlcmac_rcv_data_block_acknowledged into the pdch
Move the method into the PDCH. Extract the finding of TLLI into a new class called Decoding. Move the assemble and forward LLC frames into the TBF as it is poking in the internals of the TBF.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d1cbd4b4..d2f1fce3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -47,7 +47,8 @@ libgprs_la_SOURCES = \
poll_controller.cpp \
encoding.cpp \
ta.cpp \
- sba.cpp
+ sba.cpp \
+ decoding.cpp
if ENABLE_SYSMOBTS
libgprs_la_SOURCES += \
@@ -85,7 +86,9 @@ noinst_HEADERS = \
poll_controller.h \
encoding.h \
ta.h \
- sba.h
+ sba.h \
+ rlc.h \
+ decoding.h
osmo_pcu_SOURCES = pcu_main.cpp