aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2016-04-01 19:21:16 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2016-04-01 19:26:09 +0200
commit97e48a3252d75e714bd989504095fb197fbe832e (patch)
treed22ff18035993c54fbd056a647581de93f216e82 /debian
parent63d33ad2d79683fab33542570e20d082bb66476c (diff)
debian: Initial debian packaging
Add initial debian package for plain osmo-pcu (without the sysmoBTS supporot).
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control24
-rw-r--r--debian/osmo-pcu.install2
-rw-r--r--debian/osmo-pcu.service15
-rwxr-xr-xdebian/rules19
-rw-r--r--debian/source/format1
7 files changed, 67 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..7b7b4ad5
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+osmo-pcu (0.3) UNRELEASED; urgency=medium
+
+ * Initial release.
+
+ -- Holger Hans Peter Freyther <holger@moiji-mobile.com> Fri, 01 Apr 2016 18:59:00 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..7f8f011e
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..69930e88
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,24 @@
+Source: osmo-pcu
+Section: net
+Priority: optional
+Maintainer: Holger Hans Peter Freyther <holger@moiji-mobile.com>
+Build-Depends: debhelper (>= 7.0.0~), dh-autoreconf, dh-systemd (>= 1.5), autotools-dev, pkg-config, libosmocore-dev
+Standards-Version: 3.8.4
+Homepage: http://osmocom.org/projects/osmopcu
+Vcs-Git: git://git.osmocom.org/osmo-pcu
+Vcs-Browser: http://git.osmocom.org/osmo-pcu/
+
+Package: osmo-pcu
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: osmo-pcu GSM PCU for GPRS and EDGE
+ osmo-pcu for GPRS and EDGE support in the network
+
+Package: osmo-pcu-dbg
+Architecture: any
+Section: debug
+Priority: extra
+Depends: osmo-pcu (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for the osmo-pcu
+ Make debugging possible
+
diff --git a/debian/osmo-pcu.install b/debian/osmo-pcu.install
new file mode 100644
index 00000000..1f9a8e09
--- /dev/null
+++ b/debian/osmo-pcu.install
@@ -0,0 +1,2 @@
+etc/osmocom/osmo-pcu.cfg
+usr/bin/osmo-pcu
diff --git a/debian/osmo-pcu.service b/debian/osmo-pcu.service
new file mode 100644
index 00000000..850a7153
--- /dev/null
+++ b/debian/osmo-pcu.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Osmocom osmo-pcu
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/osmo-pcu -c /etc/osmocom/osmo-pcu.cfg
+Restart=always
+RestartSec=2
+
+# Read quickly enough
+CPUSchedulingPolicy=rr
+CPUSchedulingPriority=1
+
+[Install]
+WantedBy=multi-user.target
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..7623f748
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
+#export DH_VERBOSE=1
+export DEB_BUILD_HARDENING=1
+
+
+%:
+ dh $@ --with=systemd --with autoreconf --fail-missing
+
+override_dh_strip:
+ dh_strip --dbg-package=osmo-pcu-dbg
+
+override_dh_autoreconf:
+ echo $(VERSION) > .tarball-version
+ dh_autoreconf
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 00000000..89ae9db8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)