aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2015-11-11 21:23:23 +0100
committerHarald Welte <laforge@gnumonks.org>2015-11-12 01:01:35 +0100
commitd32cbbb13087eae2617920d4ea980f0e8869a89e (patch)
tree36f3b68fcc0f6c67fc525a8285cb6c88e479c75d /configure.ac
parent8df447dc77d69a044c6f277b369be671655590f0 (diff)
rename sysmo_sock.cpp to osmobts_sock.cpp
This also renames the --enable-sysmbts option to --enable-osmobts This socket interface was nevery sysmoBTS specific, but it is a generic socket interface to any OsmoBTS supported layer1/hardware. So it was a mis-nomer so far.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 876f7d41..b0f874b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,13 +27,13 @@ PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty)
PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 0.3.3)
PKG_CHECK_MODULES(LIBOSMOGB, libosmogb >= 0.5.1.4)
-AC_MSG_CHECKING([whether to enable sysmocom-bts hardware support])
-AC_ARG_ENABLE(sysmocom-bts,
- AC_HELP_STRING([--enable-sysmocom-bts],
- [enable code for sysmocom femto-bts [default=no]]),
- [enable_sysmocom_bts="$enableval"],[enable_sysmocom_bts="no"])
-AC_MSG_RESULT([$enable_sysmocom_bts])
-AM_CONDITIONAL(ENABLE_SYSMOBTS, test "x$enable_sysmocom_bts" = "xyes")
+AC_MSG_CHECKING([whether to enable support for the osmo-bts layer 1 support])
+AC_ARG_ENABLE(osmo-bts,
+ AC_HELP_STRING([--enable-osmo-bts],
+ [enable support for osmo-bts L1 if [default=no]]),
+ [enable_osmo_bts="$enableval"],[enable_osmo_bts="no"])
+AC_MSG_RESULT([$enable_osmo_bts])
+AM_CONDITIONAL(ENABLE_OSMOBTS, test "x$enable_osmo_bts" = "xyes")
AC_MSG_CHECKING([whether to enable direct DSP access for PDCH of sysmocom-bts])
AC_ARG_ENABLE(sysmocom-dsp,