aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-06-14 21:05:44 +0800
committerHarald Welte <laforge@gnumonks.org>2012-06-14 21:05:44 +0800
commit57f6b0220feb02b3ebc1901984aeed0ebccf7966 (patch)
tree23797e56e5e4ec91150f81203072936f114c36f3 /configure.ac
parent57875a99ac84c25a328fd98fb1fb797ef849d7ce (diff)
Add auto-foo (partial cleanup, master makefile/configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 00000000..fd9ad289
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,38 @@
+dnl Process this file with autoconf to produce a configure script
+AC_INIT([osmo-pcu],
+ m4_esyscmd([./git-version-gen .tarball-version]),
+ [osmocom-pcu@lists.openbsc.org])
+
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_INSTALL
+LT_INIT
+
+dnl checks for header files
+AC_HEADER_STDC
+
+dnl Checks for typedefs, structures and compiler characteristics
+
+dnl checks for libraries
+PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.3.9)
+PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty)
+PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 0.3.3)
+
+AC_MSG_CHECKING([whether to enable sysmocom-bts hardware support])
+AC_ARG_ENABLE(sysmocom-bts,
+ AC_HELP_STRING([--enable-sysmocom-bts],
+ [enable code for sysmocom femto-bts [default=no]]),
+ [enable_sysmocom_bts="yes"],[enable_sysmocom_bts="no"])
+AC_MSG_RESULT([$enable_sysmocom_bts])
+AM_CONDITIONAL(ENABLE_SYSMOBTS, test "x$enable_sysmocom_bts" = "xyes")
+
+AC_OUTPUT(
+ src/Makefile
+ Makefile)