aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKat <katerinab@gmail.com>2013-04-05 21:44:46 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2013-04-06 11:00:20 +0200
commit7dac4862bcdbbb182edb80ac6765736aa34e6299 (patch)
tree369b5232dc843b39e056742d6132b8d0c5ae462b /configure.ac
parent72075f0e009e103e7cfa15edf42dc40d3c373128 (diff)
Added conditional python-based tests for VTY/config handling
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f4b1d07a..dfe98a85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,21 @@ AC_ARG_ENABLE(sysmocom-dsp,
AC_MSG_RESULT([$enable_sysmocom_dsp])
AM_CONDITIONAL(ENABLE_SYSMODSP, test "x$enable_sysmocom_dsp" = "xyes")
+AC_ARG_ENABLE([vty_tests],
+ AC_HELP_STRING([--enable-vty-tests],
+ [Include the VTY tests in make check [default=yes]]),
+ [enable_vty_tests="$enableval"],[enable_vty_tests="yes"])
+if test "x$enable_vty_tests" = "xyes" ; then
+ AM_PATH_PYTHON
+ AC_CHECK_PROG(OSMOTESTVTY_CHECK,osmotestvty.py,yes)
+ if test "x$OSMOTESTVTY_CHECK" != "xyes" ; then
+ AC_MSG_ERROR([Please install osmocom-python to run the vty tests.])
+ fi
+fi
+AC_MSG_CHECKING([whether to enable VTY tests])
+AC_MSG_RESULT([$enable_vty_tests])
+AM_CONDITIONAL(ENABLE_VTY_TESTS, test "x$enable_vty_tests" = "xyes")
+
AC_OUTPUT(
src/Makefile
examples/Makefile