aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorIvan Kluchnikov <kluchnikovi@gmail.com>2012-03-05 19:24:57 +0400
committerIvan Kluchnikov <kluchnikovi@gmail.com>2012-03-05 19:24:57 +0400
commit8ee6051b723032232b811c264e6fc64f0e5a4b5f (patch)
tree9a8428f684e29e7fde0e56f36a87fb1b46eeed4c /Makefile.am
parent34506406245a9589c05cb10e484726ea226e0c0e (diff)
Separation of GPRS PCU application from main OpenBTS code and changing PCU architecture (First step).
1. pcu - main program for GPRS PCU. 2. gprs_rlcmac - RLC/MAC layer implementation for PCU. Added list for TBF, TBF allocation, establishment, release. 3. gprs_bssgp_pcu - BSSGP protocol implementation for PCU. 4. pcu_l1_if - interface for communication PCU application with OpenBTS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 3808f835..3ecb896f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,29 +28,31 @@ noinst_LTLIBRARIES = libgprs.la
libgprs_la_SOURCES = \
csn1.cpp \
gsm_rlcmac.cpp \
- bssgp.cpp \
- GPRSSocket.cpp
+ gprs_bssgp_pcu.cpp \
+ gprs_rlcmac.cpp \
+ pcu_l1_if.cpp
noinst_PROGRAMS = \
RLCMACTest \
- RLCMAC
+ pcu
noinst_HEADERS = \
csn1.h \
gsm_rlcmac.h \
- bssgp.h \
- GPRSSocket.h
+ gprs_bssgp_pcu.h \
+ gprs_rlcmac.h \
+ pcu_l1_if.h
RLCMACTest_SOURCES = RLCMACTest.cpp
RLCMACTest_LDADD = \
libgprs.la \
$(COMMON_LA)
-#OPENBSC_DIR = /path to OpenBSC dir
-#OPENGGSN_DIR = /path to OpenGGGSN dir
+OPENBSC_DIR = /home/ivan/work/openbsc/openbsc/openbsc
+OPENGGSN_DIR = /home/ivan/work/openbsc/openggsn
-RLCMAC_SOURCES = RLCMAC.cpp
-RLCMAC_LDADD = \
+pcu_SOURCES = pcu_main.cpp
+pcu_LDADD = \
libgprs.la \
$(OPENBSC_DIR)/src/libgb/gprs_ns.o \
$(OPENBSC_DIR)/src/libgb/gprs_bssgp.o \