aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-07-28 16:15:41 +0200
committerIvan Kluchnikov <kluchnikovi@gmail.com>2013-08-02 13:39:55 +0400
commitbb00704871d6d03a073f3a8a2e1e6da98046b856 (patch)
tree4b4ed9082091555ff2c7fe0c55d79041d25b8b74 /Makefile.am
parent421fe79e390b75b3442ef5b28f3a7a4ce51b2837 (diff)
tests: Create tests directory and move the VTY testing into there
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 1 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index e23a40fd..4cbc1147 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,16 +1,5 @@
AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
-SUBDIRS = src examples
+SUBDIRS = src examples tests
EXTRA_DIST = osmoappdesc.py
-if ENABLE_VTY_TESTS
-python-tests: $(BUILT_SOURCES)
- osmotestvty.py -p $(top_srcdir) -w $(builddir) -v
- osmotestconfig.py -p $(top_srcdir) -w $(builddir) -v
-else
-python-tests: $(BUILT_SOURCES)
- @echo "Not running python-based tests (determined at configure-time)"
-endif
-
-check-local: $(BUILT_SOURCES)
- $(MAKE) $(AM_MAKEFLAGS) python-tests