aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorIvan Kluchnikov <kluchnikovi@gmail.com>2011-12-21 13:17:53 +0300
committerIvan Kluchnikov <kluchnikovi@gmail.com>2011-12-21 13:17:53 +0300
commit487a141b9dcfd03f58908249b37268437f01736c (patch)
treefa6f629315390586f4cb213ae75ca6ae7a4133fb /Makefile.am
Moved CSN1 and RLC/MAC code to new GPRS directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..c5104363
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,43 @@
+#
+# Copyright 2008, 2009 Free Software Foundation, Inc.
+#
+# This software is distributed under the terms of the GNU Public License.
+# See the COPYING file in the main directory for details.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES)
+AM_CXXFLAGS = -Wall -ldl -pthread
+
+noinst_LTLIBRARIES = libgprs.la
+
+libgprs_la_SOURCES = \
+ csn1.cpp \
+ gsm_rlcmac.cpp
+
+noinst_PROGRAMS = \
+ RLCMACTest
+
+noinst_HEADERS = \
+ csn1.h \
+ gsm_rlcmac.h
+
+RLCMACTest_SOURCES = RLCMACTest.cpp
+RLCMACTest_LDADD = $(COMMON_LA)
+#MOSTLYCLEANFILES += testSource testDestination
+
+