aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorKat <katerinab@gmail.com>2013-04-05 21:44:46 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2013-04-06 11:00:20 +0200
commit7dac4862bcdbbb182edb80ac6765736aa34e6299 (patch)
tree369b5232dc843b39e056742d6132b8d0c5ae462b /Makefile.am
parent72075f0e009e103e7cfa15edf42dc40d3c373128 (diff)
Added conditional python-based tests for VTY/config handling
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2c080ed9..e23a40fd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,16 @@
AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
SUBDIRS = src examples
+EXTRA_DIST = osmoappdesc.py
+
+if ENABLE_VTY_TESTS
+python-tests: $(BUILT_SOURCES)
+ osmotestvty.py -p $(top_srcdir) -w $(builddir) -v
+ osmotestconfig.py -p $(top_srcdir) -w $(builddir) -v
+else
+python-tests: $(BUILT_SOURCES)
+ @echo "Not running python-based tests (determined at configure-time)"
+endif
+
+check-local: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) python-tests