aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorIvan Kluchnikov <kluchnikovi@gmail.com>2012-02-05 02:27:17 +0400
committerIvan Kluchnikov <ivan@kluchnikov.(none)>2012-02-05 02:28:42 +0400
commit5c2f9fbfa3e4391ab05279d9e710b1bcd46af3a8 (patch)
tree0a4f2633d78c039bf9838aeb56c2a3b91b127c27 /Makefile.am
parentd5f0133eb289fe79f2680df2c7c7fda22aac7e76 (diff)
Added RLC/MAC application.
- Segmentation of upper layer PDUs into RLC data blocks and re-assembly of RLC data blocks into upper layer PDUs. - Segmentation of RLC/MAC control messages into RLC/MAC control blocks and re-assembly of RLC/MAC control messages from RLC/MAC control blocks. - NS and BSSGP protocol implementation for communication with OpenSGSN. - UDPSocket for communication with OpenBTS.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 37 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f479b5b9..3808f835 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,19 +27,52 @@ noinst_LTLIBRARIES = libgprs.la
libgprs_la_SOURCES = \
csn1.cpp \
- gsm_rlcmac.cpp
+ gsm_rlcmac.cpp \
+ bssgp.cpp \
+ GPRSSocket.cpp
noinst_PROGRAMS = \
- RLCMACTest
+ RLCMACTest \
+ RLCMAC
noinst_HEADERS = \
csn1.h \
- gsm_rlcmac.h
+ gsm_rlcmac.h \
+ bssgp.h \
+ GPRSSocket.h
RLCMACTest_SOURCES = RLCMACTest.cpp
RLCMACTest_LDADD = \
libgprs.la \
$(COMMON_LA)
-#MOSTLYCLEANFILES += testSource testDestination
+#OPENBSC_DIR = /path to OpenBSC dir
+#OPENGGSN_DIR = /path to OpenGGGSN dir
+
+RLCMAC_SOURCES = RLCMAC.cpp
+RLCMAC_LDADD = \
+ libgprs.la \
+ $(OPENBSC_DIR)/src/libgb/gprs_ns.o \
+ $(OPENBSC_DIR)/src/libgb/gprs_bssgp.o \
+ $(OPENBSC_DIR)/src/libgb/gprs_bssgp_bss.o \
+ $(OPENBSC_DIR)/src/libgb/gprs_bssgp_util.o \
+ $(OPENBSC_DIR)/src/libgb/gprs_ns_frgre.o \
+ $(OPENGGSN_DIR)/gtp/queue.o \
+ $(OPENGGSN_DIR)/gtp/lookupa.o \
+ $(OPENGGSN_DIR)/gtp/pdp.o \
+ $(OPENGGSN_DIR)/gtp/gtpie.o \
+ $(OPENGGSN_DIR)/gtp/gtp.o \
+ $(OPENBSC_DIR)/src/gprs/sgsn_libgtp.o \
+ $(OPENBSC_DIR)/src/gprs/gprs_sndcp.o \
+ $(OPENBSC_DIR)/src/gprs/crc24.o \
+ $(OPENBSC_DIR)/src/gprs/gprs_llc.o \
+ $(OPENBSC_DIR)/src/gprs/gprs_gmm.o \
+ $(OPENBSC_DIR)/src/gprs/gprs_sgsn.o \
+ $(OPENBSC_DIR)/src/libcommon/socket.o \
+ $(OPENBSC_DIR)/src/libcommon/debug.o \
+ -losmocore \
+ -losmogsm \
+ $(COMMON_LA)
+
+#MOSTLYCLEANFILES += testSource testDestination