aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-11-06 23:40:17 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-11-06 23:42:04 +0100
commitd7999f0557c0d865122b3d45b7edf3af5f345711 (patch)
tree9b80483b7f00fd571f0375e31bba376602b6ad2a /debian/rules
parent6d06bb15009e82469ef125918614cb9cb47cc09e (diff)
debian: Update the package building
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c82a5bd..6297fcb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,6 +16,15 @@
# This has to be exported to make some magic below work.
export DH_OPTIONS
+# Maybe we require some moreadvanced testing in the future
+PCAP_CFLAGS="-I/usr/include"
+PCAP_LIBS="-lpcap"
%:
dh --with autoreconf $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --with-pcap-config=/bin/false \
+ PCAP_CFLAGS=$(PCAP_CFLAGS) \
+ PCAP_LIBS=$(PCAP_LIBS)