aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2018-12-05 15:10:30 +0100
committerHarald Welte <laforge@gnumonks.org>2018-12-05 19:35:11 +0000
commite3033b3f484f53cb2ddf042dd09bfc9179dd17b3 (patch)
tree5b1472f20ebc3e83dcec42eaac33f8956413fb56 /tests/Makefile.am
parent425bb8ea835b14bc170fc2a4a0d54fbe3c99dc7e (diff)
python tests: use py shebang instead of $(PYTHON)
I'm going to make the external tests manually launchable. For that I first had an error message if $(PYTHON) was empty. But Pau says I should just use shebang instead and ignore the autoconf python stuff, since that often fails anyway. Change-Id: Ie35dd78c42577109a6a3143221a9769e47d361a5
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c225afab9..f6b33fc42 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -46,10 +46,10 @@ if ENABLE_EXT_TESTS
python-tests: $(BUILT_SOURCES)
osmotestvty.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
osmotestconfig.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
- $(PYTHON) $(srcdir)/vty_test_runner.py -w $(abs_top_builddir) -v
- $(PYTHON) $(srcdir)/ctrl_test_runner.py -w $(abs_top_builddir) -v
+ $(srcdir)/vty_test_runner.py -w $(abs_top_builddir) -v
+ $(srcdir)/ctrl_test_runner.py -w $(abs_top_builddir) -v
if BUILD_SMPP
- $(PYTHON) $(srcdir)/smpp_test_runner.py -w $(abs_top_builddir) -v
+ $(srcdir)/smpp_test_runner.py -w $(abs_top_builddir) -v
endif
rm -f $(top_builddir)/sms.db
else