aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2018-12-05 02:24:30 +0100
committerHarald Welte <laforge@gnumonks.org>2018-12-05 19:35:11 +0000
commit18333fa5a55d84a63d9cc6a6686586b0efb0ab04 (patch)
tree70cf6047c088eb309a9686f98de13df45670ea2b /tests/Makefile.am
parent1231fdb7ad348e99926b3687908ec611451a0564 (diff)
add test_nodes.vty transcript test
It needs to work whether SMPP,Iu are enable or disabled, hence a bit more wildcarding than one might expect. Change-Id: I3a8c50d8d555b6b948d97d6412e17594ee439de0
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a6a40117b..dc5194c0a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -34,6 +34,7 @@ EXTRA_DIST = \
vty_test_runner.py \
ctrl_test_runner.py \
smpp_test_runner.py \
+ test_nodes.vty \
$(NULL)
TESTSUITE = $(srcdir)/testsuite
@@ -66,7 +67,11 @@ vty-python-test: $(BUILT_SOURCES)
# pass -u to vty_script_runner.py by doing:
# make vty-transcript-test U=-u
vty-transcript-test:
- echo "No vty-transcript-test exists yet"
+ osmo_verify_transcript_vty.py -v \
+ -n OsmoMSC -p 4254 \
+ -r "$(top_builddir)/src/osmo-msc/osmo-msc -c $(top_srcdir)/doc/examples/osmo-msc/osmo-msc.cfg" \
+ $(U) $(srcdir)/*.vty
+ rm -f $(builddir)/sms.db
# don't run multiple tests concurrently so that the ports don't conflict
vty-test: