aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-msc/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-09-04 01:03:58 +0200
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2017-09-08 23:47:37 +0000
commit6c8afe148b6e0ef8e4edd6ea4fbbdb3e6134f94b (patch)
tree24585f9c65522db4498c879c95f9031d9d26604f /src/osmo-msc/Makefile.am
parentfb11041da90a21dd9426d0c37188f85ebd575edf (diff)
use separated libosmo-mgcp-client, apply rename to mgcp_client_*
After osmo-mgw changes I8e0b2d2a399b77086a36606f5e427271c6242df1 and I99f7faab637cfcc22ece64a1dbcbe590f2042187, apply linking of new libosmo-mgcp-client and renames to drop the "gw" from mgcp_client_*. Also rename the gsm_network.mgcpgw to mgw, to indicate that the MGCP client is used to contact the MGW (Media Gateway). Depends: I8e0b2d2a399b77086a36606f5e427271c6242df1 (osmo-mgw) I99f7faab637cfcc22ece64a1dbcbe590f2042187 (osmo-mgw) Change-Id: I093ad02ca0e532f659447c785e09678b3e6f220d
Diffstat (limited to 'src/osmo-msc/Makefile.am')
-rw-r--r--src/osmo-msc/Makefile.am5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/osmo-msc/Makefile.am b/src/osmo-msc/Makefile.am
index a26b4bdc0..85a5a5ab2 100644
--- a/src/osmo-msc/Makefile.am
+++ b/src/osmo-msc/Makefile.am
@@ -17,7 +17,7 @@ AM_CFLAGS = \
$(LIBOSMORANAP_CFLAGS) \
$(LIBASN1C_CFLAGS) \
$(LIBOSMOSIGTRAN_CFLAGS) \
- $(LIBOSMOLEGACYMGCP_CFLAGS) \
+ $(LIBOSMOMGCPCLIENT_CFLAGS) \
$(NULL)
AM_LDFLAGS = \
@@ -45,8 +45,7 @@ osmo_msc_LDADD = \
$(LIBSMPP34_LIBS) \
$(LIBCRYPTO_LIBS) \
$(LIBOSMOSIGTRAN_LIBS) \
- $(LIBOSMOLEGACYMGCP_LIBS) \
- $(LIBRARY_GSM) \
+ $(LIBOSMOMGCPCLIENT_LIBS) \
-ldbi \
$(NULL)
if BUILD_IU