aboutsummaryrefslogtreecommitdiffstats
path: root/src/libvlr/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2018-03-15 12:55:46 +0100
committerNeels Hofmeyr <neels@hofmeyr.de>2018-04-16 01:50:46 +0200
commit21adb2bcd1801c6103fde7f598d8309fcbbbd6c8 (patch)
tree5fd41036c435ce81a8a550115f0a81dc7bd0f06f /src/libvlr/Makefile.am
parent37a3ae8585df2d7b8d849b194705e3ef0d2e0f6e (diff)
cosmetic: use enum ranap_nsap_addr_enc instead of int
The only reason to use int instead of the enum was the lack of header iu_client.h when not building with Iu support. Rather use the configure result properly, include the header when Iu support is built and use the proper enum. Omit the entire iu sub-struct when building without Iu. Add LIBOSMORANAP_CFLAGS to libvlr, in order to find the iu_client.h header (now also included from gsm_data.h). Rationale: Instead of using a questionable typecast from int* to enum*, we can now use the enum member directly without needing to silence compiler warnings. Change-Id: Ic9f8bf53f4b605c166e84cd7edd90c10fe7d7a1f
Diffstat (limited to 'src/libvlr/Makefile.am')
-rw-r--r--src/libvlr/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/libvlr/Makefile.am b/src/libvlr/Makefile.am
index e3d5cedf8..1408f6cd0 100644
--- a/src/libvlr/Makefile.am
+++ b/src/libvlr/Makefile.am
@@ -6,6 +6,7 @@ AM_CFLAGS= \
$(LIBOSMOSCCP_CFLAGS) \
$(LIBOSMOMGCPCLIENT_CFLAGS) \
$(LIBOSMOABIS_CFLAGS) \
+ $(LIBOSMORANAP_CFLAGS) \
$(COVERAGE_CFLAGS) \
$(NULL)