aboutsummaryrefslogtreecommitdiffstats
path: root/src/libvlr/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-12-03 11:00:04 +0100
committerPhilipp Maier <pmaier@sysmocom.de>2019-02-04 13:36:26 +0100
commit0df904dea9106587f40ec379e9cc05ea251beb7e (patch)
tree02ccf5ec37b6633677153892dee6b73a1724465f /src/libvlr/Makefile.am
parentc7de62cc53fa6ad985015403dd9af8f1627136a0 (diff)
Add SGs Interface
Add an SGs interface (3GPP TS 29.118) to osmo-msc in order to support SMS tunneling and Circuit Switched Fallback (CSFB) Change-Id: I73359925fc1ca72b33a1466e6ac41307f2f0b11d Related: OS#3615
Diffstat (limited to 'src/libvlr/Makefile.am')
-rw-r--r--src/libvlr/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/libvlr/Makefile.am b/src/libvlr/Makefile.am
index dcae1c7cf..14cd30212 100644
--- a/src/libvlr/Makefile.am
+++ b/src/libvlr/Makefile.am
@@ -8,6 +8,7 @@ AM_CFLAGS= \
$(LIBOSMOGSUPCLIENT_CFLAGS) \
$(LIBOSMOABIS_CFLAGS) \
$(LIBOSMORANAP_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
$(COVERAGE_CFLAGS) \
$(NULL)
@@ -16,6 +17,7 @@ noinst_HEADERS = \
vlr_auth_fsm.h \
vlr_core.h \
vlr_lu_fsm.h \
+ vlr_sgs_fsm.h \
$(NULL)
noinst_LIBRARIES = libvlr.a
@@ -25,4 +27,6 @@ libvlr_a_SOURCES = \
vlr_access_req_fsm.c \
vlr_auth_fsm.c \
vlr_lu_fsm.c \
+ vlr_sgs.c \
+ vlr_sgs_fsm.c \
$(NULL)