aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/gb/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-03-03 23:45:28 +0100
committerHarald Welte <laforge@gnumonks.org>2011-03-03 23:45:28 +0100
commite5e36af8aee34a252c766a34d3e00f8d165618d2 (patch)
tree2d9a286d99085f36dc3835328d1f6cabfb195dfc /openbsc/src/gb/Makefile.am
parenta17faf8512992a53a14e8b615f5369be05c5f0cc (diff)
Move 'Gb' protocol stack into its own src/gb subdirectory
Diffstat (limited to 'openbsc/src/gb/Makefile.am')
-rw-r--r--openbsc/src/gb/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/openbsc/src/gb/Makefile.am b/openbsc/src/gb/Makefile.am
new file mode 100644
index 000000000..b48b17791
--- /dev/null
+++ b/openbsc/src/gb/Makefile.am
@@ -0,0 +1,9 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)
+AM_CFLAGS=-Wall -fno-strict-aliasing $(LIBOSMOCORE_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS) $(COVERAGE_LDFLAGS)
+
+noinst_LIBRARIES = libgb.a
+
+libgb_a_SOURCES = gprs_ns.c gprs_ns_frgre.c gprs_ns_vty.c \
+ gprs_bssgp.c gprs_bssgp_util.c gprs_bssgp_vty.c
+#gprs_llc.c gprs_llc_vty.c crc24.c