aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-01-11 23:01:16 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-01-11 23:01:16 +0100
commite83a3f584e9644f127ed35967c415f19f06a03d5 (patch)
treefcbee8f76019c1e71e512a3026d182e68ffc4080 /openbsc/src/Makefile.am
parent118ddebc368f390fb5f127bdbaeb393eb20b9c59 (diff)
[bsc-nat] Start with a simple NAT/MUX for a BSC
Harald actually pointed out that this feature is just NAT. We want to connect n-real BSCs to one BSC Mux. We will talk the ip.access protocol and SCCP over of this link. The mux will drop certain GSM messages (like the reset), it will replace source local reference (NAT functionality) and it will handle some GSM08.08 specially. Get the thing started...
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index 4ad019e86..40591397a 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -2,7 +2,7 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS=-Wall
sbin_PROGRAMS = bsc_hack bs11_config ipaccess-find ipaccess-config \
- isdnsync bsc_mgcp bsc_msc_ip
+ isdnsync bsc_mgcp bsc_msc_ip bsc_nat
noinst_LIBRARIES = libbsc.a libmsc.a libvty.a libsccp.a
noinst_HEADERS = vty/cardshell.h
@@ -41,3 +41,6 @@ isdnsync_SOURCES = isdnsync.c
bsc_mgcp_SOURCES = bsc_mgcp.c msgb.c talloc.c debug.c select.c timer.c telnet_interface.c
bsc_mgcp_LDADD = libvty.a
+
+bsc_nat_SOURCES = nat/bsc_nat.c
+bsc_nat_LDADD = libbsc.a libsccp.a