aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-06-12 07:08:13 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-17 09:52:42 +0200
commit857e5e6e303a329395e2c6d2170e4904afa84d42 (patch)
tree3531eafc5edb4c3773daf6a2f954d7777157a8ee /openbsc/src/Makefile.am
parent42e327b52f603ee9b0ffa3acf84756e844735eac (diff)
[subscr] Split gsm_subscriber.c in BSC and MSC part
For the BSC part we still assign a gsm_subscriber to lchan but it might only contain the TMSI of this subscriber. For the MSC part we will need the HLR/VLR feature of the gsm_subscriber, specially the lookup's by number... So if libbsc.a/libmsc.a are compiled in one app and used the subscribers will be shared, and if only libbsc.a gets used we will have more empty gsm_subscriber.c..
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index f5febbc46..d90e48372 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -7,7 +7,7 @@ noinst_HEADERS = vty/cardshell.h
libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_04_08.c gsm_data.c mncc.c \
msgb.c select.c chan_alloc.c timer.c debug.c \
- gsm_04_11.c subchan_demux.c \
+ gsm_subscriber_base.c gsm_04_11.c subchan_demux.c \
trau_frame.c trau_mux.c paging.c e1_config.c e1_input.c tlv_parser.c \
input/misdn.c input/ipaccess.c signal.c gsm_utils.c talloc.c talloc_ctx.c \
transaction.c rtp_proxy.c bsc_rll.c token_auth.c rrlp.c