aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2009-06-12 06:53:10 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2009-08-17 09:52:42 +0200
commit42e327b52f603ee9b0ffa3acf84756e844735eac (patch)
treea96f9b1bc28fbbc89e7348c9ba3e3d7d0376cdd5 /openbsc/src/Makefile.am
parent712573b66a7957d91943d00cedd3229b8f9a5d9f (diff)
[msc] Introduce a libmsc.a library
Attempt to split up bsc/msc functionality according to the specs. The libbsc.a will be responsible for communicating with the BTS, configuring it, paging, channel allocation and passing layer3 messages in both ways. libmsc.a will implement the policy and such.
Diffstat (limited to 'openbsc/src/Makefile.am')
-rw-r--r--openbsc/src/Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/openbsc/src/Makefile.am b/openbsc/src/Makefile.am
index 448de06c0..f5febbc46 100644
--- a/openbsc/src/Makefile.am
+++ b/openbsc/src/Makefile.am
@@ -2,20 +2,22 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS=-Wall
sbin_PROGRAMS = bsc_hack bs11_config ipaccess-find ipaccess-config isdnsync
-noinst_LIBRARIES = libbsc.a libvty.a
+noinst_LIBRARIES = libbsc.a libmsc.a libvty.a
noinst_HEADERS = vty/cardshell.h
libbsc_a_SOURCES = abis_rsl.c abis_nm.c gsm_04_08.c gsm_data.c mncc.c \
- gsm_subscriber.c msgb.c select.c chan_alloc.c timer.c debug.c db.c \
- gsm_04_11.c telnet_interface.c subchan_demux.c \
+ msgb.c select.c chan_alloc.c timer.c debug.c \
+ gsm_04_11.c subchan_demux.c \
trau_frame.c trau_mux.c paging.c e1_config.c e1_input.c tlv_parser.c \
input/misdn.c input/ipaccess.c signal.c gsm_utils.c talloc.c talloc_ctx.c \
transaction.c rtp_proxy.c bsc_rll.c token_auth.c rrlp.c
+libmsc_a_SOURCES = gsm_subscriber.c db.c telnet_interface.c
+
libvty_a_SOURCES = vty/buffer.c vty/command.c vty/vector.c vty/vty.c
bsc_hack_SOURCES = bsc_hack.c vty_interface.c
-bsc_hack_LDADD = libbsc.a libvty.a -ldl -ldbi $(LIBCRYPT)
+bsc_hack_LDADD = libbsc.a libmsc.a libvty.a -ldl -ldbi $(LIBCRYPT)
bs11_config_SOURCES = bs11_config.c abis_nm.c gsm_data.c msgb.c debug.c \
select.c timer.c rs232.c tlv_parser.c signal.c talloc.c
@@ -23,6 +25,6 @@ bs11_config_SOURCES = bs11_config.c abis_nm.c gsm_data.c msgb.c debug.c \
ipaccess_find_SOURCES = ipaccess-find.c select.c timer.c
ipaccess_config_SOURCES = ipaccess-config.c
-ipaccess_config_LDADD = libbsc.a libvty.a -ldl -ldbi $(LIBCRYPT)
+ipaccess_config_LDADD = libbsc.a libmsc.a libvty.a -ldl -ldbi $(LIBCRYPT)
isdnsync_SOURCES = isdnsync.c