aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorOliver Smith <osmith@sysmocom.de>2019-05-22 13:48:28 +0200
committerOliver Smith <osmith@sysmocom.de>2019-05-29 12:14:16 +0200
commita2273f5f1d3719543eb0ab922c19952b651a2ccf (patch)
tree9c746f99ad74127fa2e7c31cb50b14ddc73fc5a3 /debian
parent8b0737fa71ea4b04cee8dc61c79a1f93779e66dc (diff)
debian: create -doc subpackage with pdf manuals
I have verified, that the resulting debian packages build in my own OBS namespace (see the -doc packages): https://download.opensuse.org/repositories/home:/osmith42/Debian_9.0/all/ https://build.opensuse.org/project/show/home:osmith42 Depends: Ib7251cca9116151e473798879375cd5eb48ff3ad (osmo-ci) Related: OS#3899 Change-Id: Iafa9fba60b3ad4478ec24d6ba8538ec80ce99f52
Diffstat (limited to 'debian')
-rw-r--r--debian/control12
-rw-r--r--debian/osmo-msc-doc.install1
-rwxr-xr-xdebian/rules6
3 files changed, 17 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 54a35469c..8b0d6903d 100644
--- a/debian/control
+++ b/debian/control
@@ -21,7 +21,8 @@ Build-Depends: debhelper (>=9),
libosmo-mgcp-client-dev (>= 1.1.0),
libosmo-gsup-client-dev (>= 0.2.1),
libosmo-netif-dev (>= 0.1.0),
- libosmo-ranap-dev (>= 0.2.0)
+ libosmo-ranap-dev (>= 0.2.0),
+ osmo-gsm-manuals-dev
Standards-Version: 3.9.8
Vcs-Git: git://git.osmocom.org/osmo-msc.git
Vcs-Browser: https://git.osmocom.org/osmo-msc/
@@ -62,3 +63,12 @@ Description: OsmoMSC: Osmocom's Mobile Switching Center for 2G and 3G circuit-sw
.
This package contains the debug symbols for osmo-msc in order to
generate meaningful backtraces in bug-reports.
+
+Package: osmo-msc-doc
+Architecture: all
+Section: doc
+Priority: optional
+Depends: ${misc:Depends}
+Description: ${misc:Package} PDF documentation
+ Various manuals: user manual, VTY reference manual and/or
+ protocol/interface manuals.
diff --git a/debian/osmo-msc-doc.install b/debian/osmo-msc-doc.install
new file mode 100644
index 000000000..ee15cf912
--- /dev/null
+++ b/debian/osmo-msc-doc.install
@@ -0,0 +1 @@
+usr/share/doc/osmo-msc-doc/*.pdf
diff --git a/debian/rules b/debian/rules
index 1cf3a355e..5925ca976 100755
--- a/debian/rules
+++ b/debian/rules
@@ -46,7 +46,7 @@
# debmake generated override targets
# Set options for ./configure
-CONFIGURE_FLAGS += --enable-iu --enable-smpp --with-systemdsystemunitdir=/lib/systemd/system
+CONFIGURE_FLAGS += --enable-iu --enable-smpp --with-systemdsystemunitdir=/lib/systemd/system --enable-manuals
override_dh_auto_configure:
dh_auto_configure -- $(CONFIGURE_FLAGS)
#
@@ -61,3 +61,7 @@ override_dh_strip:
# Print test results in case of a failure
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+
+# Don't create .pdf.gz files (barely saves space and they can't be opened directly by most pdf readers)
+override_dh_compress:
+ dh_compress -X.pdf