aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-08-06 21:52:02 +0000
committerAlexander Couzens <lynxis@fe80.eu>2017-08-13 04:21:13 +0200
commite485cdd38b363d84b3f6abc7e683c03c9a882d54 (patch)
treee469f5912c2d00fd703b694b0f159f5676786e53 /debian/rules
parentecbdc5cb06ef7f61c6f4cdb4e1fd84a05ec0407d (diff)
add /debian package support0.1.0
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 18 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..03432e6
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
+# main packaging script based on dh7 syntax
+%:
+ dh $@ --with autoreconf
+
+override_dh_autoreconf:
+ echo $(VERSION) > .tarball-version
+ dh_autoreconf
+
+# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
+override_dh_strip:
+ dh_strip --dbg-package=libosmo-ranap-dbg
+ dh_strip --dbg-package=osmo-hnbgw