aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Willmann <dwillmann@sysmocom.de>2015-12-15 15:10:31 +0100
committerDaniel Willmann <dwillmann@sysmocom.de>2015-12-15 15:10:31 +0100
commit29b9e00355d148be2500d361f2f284e6fa86bab9 (patch)
tree00ef16ebc16fcfb20fa79148bec30d304eda260e /configure.ac
parenta7b02405be1617c6b643fabb34275dc2559b8210 (diff)
Autotoolize the build
Use Autoconf/make for building and autotest for tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 34 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f125726
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,34 @@
+AC_INIT([osmo-iuh], [0.0],
+dnl m4_esyscmd([./git-version-gen .tarball-version]),
+ [openbsc@lists.osmocom.org])
+
+AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip 1.6 subdir-objects])
+AC_CONFIG_TESTDIR(src/tests)
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_MKDIR_P
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_RANLIB
+
+PKG_CHECK_MODULES(OSMOCORE, libosmocore)
+PKG_CHECK_MODULES(OSMOGSM, libosmogsm)
+PKG_CHECK_MODULES(OSMOVTY, libosmovty)
+PKG_CHECK_MODULES(ASN1C, libasn1c)
+
+AC_CONFIG_MACRO_DIR([m4])
+
+dnl checks for header files
+AC_HEADER_STDC
+
+AC_OUTPUT(
+ src/Makefile
+ src/hnbap/Makefile
+ src/ranap/Makefile
+ src/rua/Makefile
+ src/tests/Makefile
+ Makefile)