aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2017-10-27 02:46:11 +0200
committerHarald Welte <laforge@gnumonks.org>2017-10-28 16:49:32 +0000
commit99a14c8ca1d1675bb7220376d6438d3d73c20fd6 (patch)
treef0aa9be594708e69d38b0406e058a1572573df9a /tests/Makefile.am
parentc6a6d26f50fe87a5f67699f9696d63d9dfd39210 (diff)
tests/Makefile: use test db var instead of repeating the path
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e71a250..2dba6a1 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -54,7 +54,7 @@ vty-test:
sqlite3 $(VTY_TEST_DB) < $(top_srcdir)/sql/hlr.sql
osmo_verify_transcript_vty.py -v \
-n OsmoHLR -p 4258 \
- -r "$(top_builddir)/src/osmo-hlr -c $(top_srcdir)/doc/examples/osmo-hlr.cfg -l hlr_vty_test.db" \
+ -r "$(top_builddir)/src/osmo-hlr -c $(top_srcdir)/doc/examples/osmo-hlr.cfg -l $(VTY_TEST_DB)" \
$(U) $(srcdir)/*.vty
-rm -f $(VTY_TEST_DB)
@@ -69,7 +69,7 @@ ctrl-test:
sqlite3 $(CTRL_TEST_DB) < $(srcdir)/test_subscriber.sql
osmo_verify_transcript_ctrl.py -v \
-p 4259 \
- -r "$(top_builddir)/src/osmo-hlr -c $(top_srcdir)/doc/examples/osmo-hlr.cfg -l hlr_ctrl_test.db" \
+ -r "$(top_builddir)/src/osmo-hlr -c $(top_srcdir)/doc/examples/osmo-hlr.cfg -l $(CTRL_TEST_DB)" \
$(U) $(srcdir)/*.ctrl
-rm -f $(CTRL_TEST_DB)