aboutsummaryrefslogtreecommitdiffstats
path: root/include/osmocom/hlr/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2019-11-20 03:35:37 +0100
committerNeels Hofmeyr <neels@hofmeyr.de>2020-04-30 19:22:24 +0200
commitab7dc40f168da4326f207ef8aeeec40229c94486 (patch)
treece45f461c6dee3a93ee99eb98e5af7ca8cb2257c /include/osmocom/hlr/Makefile.am
parent86b507b6ea529f9cf861286d8e6fa3b5fde851d2 (diff)
D-GSM 1/n: add mslookup server in osmo-hlr
Implement the mslookup server to service remote mslookup requests. This patch merely adds the logic to answer incoming mslookup requests, an actual method to receive requests (mDNS) follows in a subsequent patch. - API to configure service names and addresses for the local site (per MSC). - determine whether a subscriber is on a local MSC (checking the local proxy will be added in subsequent patch that adds proxy capability). - VTY config follows in a subsequent patch. For a detailed overview of the D-GSM and mslookup related files, please see the elaborate comment at the top of mslookup.c (already added in an earlier patch). Change-Id: Ife4a61d71926d08f310a1aeed9d9f1974f64178b
Diffstat (limited to 'include/osmocom/hlr/Makefile.am')
-rw-r--r--include/osmocom/hlr/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/osmocom/hlr/Makefile.am b/include/osmocom/hlr/Makefile.am
index 532fa5d..5c96ec8 100644
--- a/include/osmocom/hlr/Makefile.am
+++ b/include/osmocom/hlr/Makefile.am
@@ -10,5 +10,7 @@ noinst_HEADERS = \
hlr_vty_subscr.h \
logging.h \
lu_fsm.h \
+ mslookup_server.h \
rand.h \
+ timestamp.h \
$(NULL)