aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-12-11 00:27:48 +0100
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2016-12-11 01:07:26 +0100
commit40d8b01deae185a3f043c242842e254ae67a42c2 (patch)
tree638e9877020cc113306d04220629175a1c607422 /configure.ac
parent7f8c3010058ae6d0cda8f651931068195af8a19b (diff)
build with autoconf/automake, add jenkins.sh script
Add configure.ac and Makefile.ams to build with autoreconf && ./configure && make like most other Osmocom projects. Add jenkins.sh for a gerrit build job to verify patches. Change-Id: I6b4419dd519f3d0a75235d0c22bf899f075347a3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 50 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..189a53a
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,50 @@
+AC_INIT([osmo-hlr],
+ m4_esyscmd([./git-version-gen .tarball-version]),
+ [openbsc@lists.osmocom.org])
+
+dnl *This* is the root dir, even if an install-sh exists in ../ or ../../
+AC_CONFIG_AUX_DIR([.])
+
+dnl libtool init
+LT_INIT
+
+AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip 1.9])
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_MKDIR_P
+AC_PROG_CC
+AC_PROG_INSTALL
+
+dnl check for pkg-config (explained in detail in libosmocore/configure.ac)
+AC_PATH_PROG(PKG_CONFIG_INSTALLED, pkg-config, no)
+if test "x$PKG_CONFIG_INSTALLED" = "xno"; then
+ AC_MSG_WARN([You need to install pkg-config])
+fi
+PKG_PROG_PKG_CONFIG([0.20])
+
+PKG_CHECK_MODULES(TALLOC, [talloc >= 2.0.1])
+
+PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.9.0)
+PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 0.9.0)
+PKG_CHECK_MODULES(LIBOSMOVTY, libosmovty >= 0.9.0)
+PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 0.3.2)
+
+found_sqlite3=yes
+PKG_CHECK_MODULES(SQLITE3, sqlite3, ,found_sqlite3=no)
+AM_CONDITIONAL(HAVE_SQLITE3, test "$found_sqlite3" = yes)
+AC_SUBST(found_sqlite3)
+
+AC_CONFIG_MACRO_DIR([m4])
+
+dnl checks for header files
+AC_HEADER_STDC
+
+AC_OUTPUT(
+ Makefile
+ src/Makefile
+ sql/Makefile
+ )