aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-11-16 01:01:09 +0100
committerHarald Welte <laforge@gnumonks.org>2017-11-17 14:27:40 +0000
commit38f08770a3a40cc90caf2879c9ff545a3e58f714 (patch)
tree22fa04879ea28c6bfa88d09f40b8bb1e1920c2e0
parentaee7be901bbc91ef63449595727a5096bb65c09b (diff)
doc: install example .cfg files to $(docdir)/examples/
-rw-r--r--Makefile.am1
-rw-r--r--configure.ac1
-rw-r--r--debian/osmo-hlr.install1
-rw-r--r--doc/Makefile.am22
4 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 392d80d..f5062a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
AUTOMAKE_OPTIONS = foreign dist-bzip2
SUBDIRS = \
+ doc \
src \
sql \
tests \
diff --git a/configure.ac b/configure.ac
index 1db32d4..d72a026 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,7 @@ AM_CONDITIONAL(ENABLE_EXT_TESTS, test "x$enable_ext_tests" = "xyes")
AC_OUTPUT(
Makefile
+ doc/Makefile
src/Makefile
sql/Makefile
tests/Makefile
diff --git a/debian/osmo-hlr.install b/debian/osmo-hlr.install
index 0e2a1c4..1e3bbc6 100644
--- a/debian/osmo-hlr.install
+++ b/debian/osmo-hlr.install
@@ -1,3 +1,4 @@
/usr/bin/osmo-hlr
/usr/bin/osmo-hlr-db-tool
/usr/share/doc/osmo-hlr/hlr.sql
+/usr/share/doc/osmo-hlr/examples/osmo-hlr.cfg
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..e0e5380
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,22 @@
+CFG_FILES = find $(srcdir) -name '*.cfg*' | sed -e 's,^$(srcdir),,'
+
+dist-hook:
+ for f in $$($(CFG_FILES)); do \
+ j="$(distdir)/$$f" && \
+ mkdir -p "$$(dirname $$j)" && \
+ $(INSTALL_DATA) $(srcdir)/$$f $$j; \
+ done
+
+install-data-hook:
+ for f in $$($(CFG_FILES)); do \
+ j="$(DESTDIR)$(docdir)/$$f" && \
+ mkdir -p "$$(dirname $$j)" && \
+ $(INSTALL_DATA) $(srcdir)/$$f $$j; \
+ done
+
+uninstall-hook:
+ @$(PRE_UNINSTALL)
+ for f in $$($(CFG_FILES)); do \
+ j="$(DESTDIR)$(docdir)/$$f" && \
+ $(RM) $$j; \
+ done