aboutsummaryrefslogtreecommitdiffstats
path: root/tests/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/lib/Makefile.am')
-rw-r--r--tests/lib/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/lib/Makefile.am b/tests/lib/Makefile.am
new file mode 100644
index 0000000..ee46468
--- /dev/null
+++ b/tests/lib/Makefile.am
@@ -0,0 +1,28 @@
+AM_CFLAGS = -Wall -I$(top_srcdir)/include $(LIBOSMOCORE_CFLAGS) -g
+
+EXTRA_DIST = ippool_test.ok \
+ ippool_test.err \
+ ippool_v6_test.ok \
+ ippool_v6_test.err \
+ in46a_test.ok \
+ in46a_v6_test.ok
+
+noinst_PROGRAMS = ippool_test in46a_test
+
+ippool_test_SOURCES = \
+ ippool_test.c \
+ $(NULL)
+
+ippool_test_LDADD = \
+ $(top_builddir)/lib/libmisc.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(NULL)
+
+in46a_test_SOURCES = \
+ in46a_test.c \
+ $(NULL)
+
+in46a_test_LDADD = \
+ $(top_builddir)/lib/libmisc.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(NULL)