aboutsummaryrefslogtreecommitdiffstats
path: root/gtp/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-12-03 20:18:43 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-12-04 16:45:59 +0100
commit42ca1d1a38a41f0377145c6243d42d1782dc304b (patch)
treed06a3b6e18a558fad226ceee01669e79688d9655 /gtp/Makefile.am
parentca524ef344edcecf07d84a2cff7d14acd018486c (diff)
gtp: Move to using LOGP for logging GTP packages
Make libgtp depend on libosmocore and use the generic logging infrastructure for it.
Diffstat (limited to 'gtp/Makefile.am')
-rw-r--r--gtp/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gtp/Makefile.am b/gtp/Makefile.am
index ea73a67..4ad9f65 100644
--- a/gtp/Makefile.am
+++ b/gtp/Makefile.am
@@ -2,9 +2,10 @@ lib_LTLIBRARIES = libgtp.la
include_HEADERS = gtp.h pdp.h
-AM_CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"' -ggdb
+AM_CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"' -ggdb $(LIBOSMOCORE_CFLAGS)
libgtp_la_SOURCES = gtp.c gtp.h gtpie.c gtpie.h pdp.c pdp.h lookupa.c lookupa.h queue.c queue.h
+libgtp_la_LIBADD = $(LIBOSMOCORE_LIBS)