aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-08-13 09:41:33 +0200
committerHarald Welte <laforge@gnumonks.org>2017-08-14 00:21:57 +0200
commit367baa3776476d3fd33d8a73f1f2572e09e06368 (patch)
treedab15e6b296c89a6a5652857fd924a7d1f5595b3 /debian/rules
parent37d5b1557b4c15b59ab3fe432faa5b7bf7c5a2a3 (diff)
update debian/changelog to 0.94 + fix pkg-config version
This updates the debian changelog to 0.94 and adds some logic to debian/rulres which fixes the version of the libgtp.pc file built as part of our OBS builds (used to be UNKNOWN since commit 23eea1d132120198745dcca32728906d5f05dc5f) Change-Id: I883feaef35ff5ffd1b22fb255b7c36112b4a8f3b
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 8710fa0..aa95e28 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,10 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
# This has to be exported to make some magic below work.
#export DH_OPTIONS
export DEB_BUILD_MAINT_OPTIONS = hardening=+all