aboutsummaryrefslogtreecommitdiffstats
path: root/tests/bursts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/bursts/Makefile.am')
-rw-r--r--tests/bursts/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/bursts/Makefile.am b/tests/bursts/Makefile.am
new file mode 100644
index 00000000..462b7288
--- /dev/null
+++ b/tests/bursts/Makefile.am
@@ -0,0 +1,14 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(OPENBSC_INCDIR)
+AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOCODEC_CFLAGS)
+LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOCODEC_LIBS)
+noinst_PROGRAMS = bursts_test
+EXTRA_DIST = bursts_test.ok
+
+bursts_test_SOURCES = bursts_test.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_coding.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_conv.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_interleaving.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_mapping.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_tables.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_parity.c
+bursts_test_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)