aboutsummaryrefslogtreecommitdiffstats
path: root/tests/agch/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/agch/Makefile.am')
-rw-r--r--tests/agch/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/agch/Makefile.am b/tests/agch/Makefile.am
new file mode 100644
index 00000000..a0c5eeda
--- /dev/null
+++ b/tests/agch/Makefile.am
@@ -0,0 +1,8 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(OPENBSC_INCDIR)
+AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOTRAU_CFLAGS)
+LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(LIBOSMOTRAU_LIBS) $(LIBOSMOABIS_LIBS) -lortp
+noinst_PROGRAMS = agch_test
+EXTRA_DIST = agch_test.ok
+
+agch_test_SOURCES = agch_test.c $(srcdir)/../stubs.c
+agch_test_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)