aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-bts-trx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/osmo-bts-trx/Makefile.am')
-rw-r--r--src/osmo-bts-trx/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/osmo-bts-trx/Makefile.am b/src/osmo-bts-trx/Makefile.am
index 54d1af9e..7317fdc9 100644
--- a/src/osmo-bts-trx/Makefile.am
+++ b/src/osmo-bts-trx/Makefile.am
@@ -51,6 +51,7 @@ osmo_bts_trx_SOURCES = \
trx_provision_fsm.c \
trx_vty.c \
loops.c \
+ probes.d \
$(NULL)
osmo_bts_trx_LDADD = \
@@ -58,3 +59,14 @@ osmo_bts_trx_LDADD = \
$(top_builddir)/src/common/libbts.a \
$(LDADD) \
$(NULL)
+
+if ENABLE_SYSTEMTAP
+probes.h: probes.d
+ $(DTRACE) -C -h -s $< -o $@
+
+probes.lo: probes.d
+ $(LIBTOOL) --mode=compile $(AM_V_lt) --tag=CC env CFLAGS="$(CFLAGS)" $(DTRACE) -C -G -s $< -o $@
+
+BUILT_SOURCES = probes.h probes.lo
+osmo_bts_trx_LDADD += probes.lo
+endif