aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ccca24fc..ef583d36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,11 @@ AM_CONDITIONAL(ENABLE_SYSMOBTS, test "x$enable_sysmocom_bts" = "xyes")
# We share gsm_data.h with OpenBSC and need to be pointed to the source
# directory of OpenBSC for now.
-openbsc_incdir="\$(abs_top_srcdir)/../openbsc/openbsc/include"
+AC_ARG_WITH([openbsc],
+ [AS_HELP_STRING([--with-openbsc=INCLUDE_DIR],
+ [OpenBSC include directory for openbsc/gsm_data_shared.h])],
+ [openbsc_incdir="$withval"],
+ [openbsc_incdir="\$(abs_top_srcdir)/../openbsc/openbsc/include"])
AC_SUBST([OPENBSC_INCDIR], $openbsc_incdir)
AC_OUTPUT(