aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 641a6c9a..752e85b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,14 @@ AC_ARG_ENABLE(sysmocom-bts,
AC_MSG_RESULT([$enable_sysmocom_bts])
AM_CONDITIONAL(ENABLE_SYSMOBTS, test "x$enable_sysmocom_bts" = "xyes")
+AC_MSG_CHECKING([whether to enable trx hardware support])
+AC_ARG_ENABLE(trx,
+ AC_HELP_STRING([--enable-trx],
+ [enable code for trx hardware [default=no]]),
+ [enable_trx="yes"],[enable_trx="no"])
+AC_MSG_RESULT([$enable_trx])
+AM_CONDITIONAL(ENABLE_TRX, test "x$enable_trx" = "xyes")
+
# We share gsm_data.h with OpenBSC and need to be pointed to the source
# directory of OpenBSC for now.
AC_ARG_WITH([openbsc],
@@ -70,6 +78,7 @@ AC_OUTPUT(
src/Makefile
src/common/Makefile
src/osmo-bts-sysmo/Makefile
+ src/osmo-bts-trx/Makefile
include/Makefile
include/osmo-bts/Makefile
tests/Makefile