aboutsummaryrefslogtreecommitdiffstats
path: root/tests/paging/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-12-01 09:12:47 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2011-12-01 09:14:32 +0100
commitb0985e3fa5ad539f1ab51ebf89724eb8e616a750 (patch)
tree211803084bedbda9ad4968a46be4195f3688bb6a /tests/paging/Makefile.am
parent467e1497630a093cff94670da0e8fa39fd21c278 (diff)
test: Introduce a very simple test for the paging subsystem
Check that adding a paging command works, check that it is expired after the first call to paging_gen_msg. The test will be extended to test the scheduling and selection of the various paging messages.
Diffstat (limited to 'tests/paging/Makefile.am')
-rw-r--r--tests/paging/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/paging/Makefile.am b/tests/paging/Makefile.am
new file mode 100644
index 00000000..d5743a65
--- /dev/null
+++ b/tests/paging/Makefile.am
@@ -0,0 +1,8 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOTRAU_CFLAGS)
+LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(LIBOSMOTRAU_LIBS) -lortp
+noinst_PROGRAMS = paging_test
+EXTRA_DIST = paging_test.ok
+
+paging_test_SOURCES = paging_test.c
+paging_test_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)