aboutsummaryrefslogtreecommitdiffstats
path: root/tests/bursts/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2015-09-22 16:41:54 +0200
committerHarald Welte <laforge@gnumonks.org>2015-09-22 16:41:54 +0200
commitf1fb0fa3af174c605f60458388bba61ef4f40fa8 (patch)
tree006e46f78dee0ac14ffd321e0bfae344d8160096 /tests/bursts/Makefile.am
parent329085a8ff2c1162a32eb617068fa5614efcde06 (diff)
parentcaa648d92e48a05e676e87b48c21cb0b151c9b4e (diff)
Merge branch '201509-trx-rebase'0.4.0
Diffstat (limited to 'tests/bursts/Makefile.am')
-rw-r--r--tests/bursts/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/bursts/Makefile.am b/tests/bursts/Makefile.am
new file mode 100644
index 00000000..462b7288
--- /dev/null
+++ b/tests/bursts/Makefile.am
@@ -0,0 +1,14 @@
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include -I$(OPENBSC_INCDIR)
+AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOCODEC_CFLAGS)
+LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOCODEC_LIBS)
+noinst_PROGRAMS = bursts_test
+EXTRA_DIST = bursts_test.ok
+
+bursts_test_SOURCES = bursts_test.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_coding.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_conv.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_interleaving.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_mapping.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_tables.c \
+ $(top_builddir)/src/osmo-bts-trx/gsm0503_parity.c
+bursts_test_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)