aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-bts-sysmo/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-07-11 01:31:28 +0200
committerHarald Welte <laforge@gnumonks.org>2012-07-11 01:32:42 +0200
commit38420fb9513db552d80629035ef4e92315e35b6d (patch)
tree1d0542a1b8beb65db377598dff98e2793be339c4 /src/osmo-bts-sysmo/Makefile.am
parent3696c6946d9b0e683093dd6e87d16629f236d4f9 (diff)
add new sysmobst-mgr daemon
This daemon is taking care of counting the number of hours in operation and to watch the system temperature as determined by internal temperature sensors. Later, it will export an external interface for firmware reload, as well as a way to raise OML ALARMs in case of temperature issues or other problems.
Diffstat (limited to 'src/osmo-bts-sysmo/Makefile.am')
-rw-r--r--src/osmo-bts-sysmo/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/osmo-bts-sysmo/Makefile.am b/src/osmo-bts-sysmo/Makefile.am
index ab3e706f..e69ee2ac 100644
--- a/src/osmo-bts-sysmo/Makefile.am
+++ b/src/osmo-bts-sysmo/Makefile.am
@@ -2,7 +2,9 @@ INCLUDES = $(all_includes) -I$(top_srcdir)/include
AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(LIBOSMOTRAU_CFLAGS)
LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(LIBOSMOTRAU_LIBS) -lortp
-bin_PROGRAMS = sysmobts sysmobts-remote l1fwd-proxy
+EXTRA_DIST = misc/sysmobts_mgr.h misc/sysmobts_misc.h misc/sysmobts_par.h misc/sysmobts_eeprom.h
+
+bin_PROGRAMS = sysmobts sysmobts-remote l1fwd-proxy sysmobts-mgr
COMMON_SOURCES = main.c femtobts.c l1_if.c oml.c sysmobts_vty.c tch.c hw_misc.c
@@ -14,3 +16,5 @@ sysmobts_remote_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)
l1fwd_proxy_SOURCES = l1_fwd_main.c l1_transp_hw.c
l1fwd_proxy_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)
+
+sysmobts_mgr_SOURCES = misc/sysmobts_mgr.c misc/sysmobts_misc.c misc/sysmobts_par.c