aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-bts-sysmo/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-05-25 14:43:03 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-07-31 16:57:39 +0200
commitb05d72d21b8cc91126cf45525f9010df6142e1c2 (patch)
treee620d3078f7c2176756c62fe94827d79a38add64 /src/osmo-bts-sysmo/Makefile.am
parent9e1dbf532e4450f99797b7a8e580172449c615aa (diff)
sysmobts: Begin with an OML router that will be used by the manager
Begin with the basics of a OML Router. This is currently only capable of accepting a connection and read messages but it will evolve into a router in multiple stages. The first usage will be by the sysmobts-mgr. An OML Error Indication will be sent by the sysmobts-mgr and it will be forwarded to the BSC. In the second step we will set a relative power reduction from the sysmobts-mgr. In the long-term this code will be used to communicate with a second TRX.
Diffstat (limited to 'src/osmo-bts-sysmo/Makefile.am')
-rw-r--r--src/osmo-bts-sysmo/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/osmo-bts-sysmo/Makefile.am b/src/osmo-bts-sysmo/Makefile.am
index 1c08af3a..a213759e 100644
--- a/src/osmo-bts-sysmo/Makefile.am
+++ b/src/osmo-bts-sysmo/Makefile.am
@@ -4,12 +4,12 @@ COMMON_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(LIBOS
EXTRA_DIST = misc/sysmobts_mgr.h misc/sysmobts_misc.h misc/sysmobts_par.h \
misc/sysmobts_eeprom.h misc/sysmobts_nl.h femtobts.h hw_misc.h \
- l1_fwd.h l1_if.h l1_transp.h eeprom.h utils.h
+ l1_fwd.h l1_if.h l1_transp.h eeprom.h utils.h oml_router.h
bin_PROGRAMS = sysmobts sysmobts-remote l1fwd-proxy sysmobts-mgr sysmobts-util
COMMON_SOURCES = main.c femtobts.c l1_if.c oml.c sysmobts_vty.c tch.c hw_misc.c calib_file.c \
- eeprom.c calib_fixup.c utils.c misc/sysmobts_par.c
+ eeprom.c calib_fixup.c utils.c misc/sysmobts_par.c oml_router.c
sysmobts_SOURCES = $(COMMON_SOURCES) l1_transp_hw.c
sysmobts_LDADD = $(top_builddir)/src/common/libbts.a $(COMMON_LDADD)