aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-bts-sysmo/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-08-21 22:52:50 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-08-21 23:55:27 +0200
commitb0674e9636a5010b1d9a17496afa1f6ffc1fc79b (patch)
treef1c93387fd754052d2edb5c03cd76481cf0eaaf6 /src/osmo-bts-sysmo/Makefile.am
parentd036cce744b4c0da6b147fe94d7f8ce723f8bb30 (diff)
sysmobts: Implement a small state machine for temp control
Check the temperature and move between "NORMAL", "WARNING" and "CRITICAL" state. We will only return from CRITICAL to WARNING when the temperature has significantly changed, and when being in state "WARNING" we enter an intermediate state to allow an easy hysteris.
Diffstat (limited to 'src/osmo-bts-sysmo/Makefile.am')
-rw-r--r--src/osmo-bts-sysmo/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/osmo-bts-sysmo/Makefile.am b/src/osmo-bts-sysmo/Makefile.am
index dc753f50..cc669339 100644
--- a/src/osmo-bts-sysmo/Makefile.am
+++ b/src/osmo-bts-sysmo/Makefile.am
@@ -25,7 +25,8 @@ sysmobts_mgr_SOURCES = \
misc/sysmobts_par.c misc/sysmobts_nl.c \
misc/sysmobts_mgr_2050.c \
misc/sysmobts_mgr_vty.c \
- misc/sysmobts_mgr_nl.c
+ misc/sysmobts_mgr_nl.c \
+ misc/sysmobts_mgr_temp.c
sysmobts_mgr_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS)
sysmobts_util_SOURCES = misc/sysmobts_util.c misc/sysmobts_par.c