aboutsummaryrefslogtreecommitdiffstats
path: root/src/osmo-bts-sysmo/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-06-27 11:25:35 +0200
committerHarald Welte <laforge@gnumonks.org>2011-06-27 11:25:35 +0200
commitc6b4c87e5d57b91b29894835e7ac8e42f6e67f32 (patch)
tree2dfca5a61c881e88e6f29d03c29bb26e1c643332 /src/osmo-bts-sysmo/Makefile.am
parent8e47fb89bfd0e2b54b714393ac2a80ca76df56a9 (diff)
re-work original osmo-bts with support for sysmocom femtobts
This code re-works osmo-bts to add support for the upcoming sysmocom BTS. It also tries to add some level of abstraction between the generic part of a BTS (A-bis, RSL, OML, data structures, paging scheduling, BCCH/AGCH scheduling, etc.) and the actual hardware-specific bits. The hardware-specific bits are currently only implemented for the sysmocom femtobts, but should be (re-)added for osmocom-bb, as well as a virtual BTS for simulation purpose later. The sysmocom bts specific parts require hardware-specific header files which are (at least currently) not publicly distributed.
Diffstat (limited to 'src/osmo-bts-sysmo/Makefile.am')
-rw-r--r--src/osmo-bts-sysmo/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/osmo-bts-sysmo/Makefile.am b/src/osmo-bts-sysmo/Makefile.am
new file mode 100644
index 00000000..6b00b9e3
--- /dev/null
+++ b/src/osmo-bts-sysmo/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS = -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOVTY_CFLAGS)
+LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS)
+
+bin_PROGRAMS = sysmobts sysmobts-remote l1fwd-proxy
+
+COMMON_SOURCES = main.c femtobts.c l1_if.c oml.c bts_model.c
+
+sysmobts_SOURCES = $(COMMON_SOURCES) l1_transp_hw.c
+sysmobts_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)
+
+sysmobts_remote_SOURCES = $(COMMON_SOURCES) l1_transp_fwd.c
+sysmobts_remote_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)
+
+l1fwd_proxy_SOURCES = l1_fwd_main.c l1_transp_hw.c
+l1fwd_proxy_LDADD = $(top_builddir)/src/common/libbts.a $(LDADD)