aboutsummaryrefslogtreecommitdiffstats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2014-08-24 10:44:31 +0200
committerHarald Welte <laforge@gnumonks.org>2014-08-24 16:42:02 +0200
commitd9a2aa8d9909d93d96e421c7cb727932445fa8ab (patch)
treea5d58e1a563ed7feb35ce7bc7d973f0e4038686e /src/common/Makefile.am
parente43feaf231e08f108aafa26a7829820fad3447cb (diff)
add control interface to common BTS (for thermal attenuation)
Using this control interface, an external program can request attentuation of the transmitter for thermal management reasons. The external application doesn't have to know anthing about the actual transmit power, but it can just configure a certian value of milli-dB (1/10000 bel) and update (increase/decrease) that value depending on the thermal environment.
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 77f73b47..10627e2a 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -7,4 +7,4 @@ libbts_a_SOURCES = gsm_data_shared.c sysinfo.c logging.c abis.c oml.c bts.c \
rsl.c vty.c paging.c measurement.c amr.c lchan.c \
load_indication.c pcu_sock.c handover.c msg_utils.c \
load_indication.c pcu_sock.c handover.c msg_utils.c \
- tx_power.c
+ tx_power.c bts_ctrl_commands.c bts_ctrl_lookup.c