aboutsummaryrefslogtreecommitdiffstats
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2014-08-18 19:14:58 +0200
committerHarald Welte <laforge@gnumonks.org>2014-08-24 17:29:16 +0200
commit54cbbb14503f3a99c13a882e67433b66c06235b9 (patch)
tree7f2f43f9c053e706ed4204b7451e53a857d21c69 /src/common/Makefile.am
parent3d836bcf3097d1fb09fd98eca10558b4fdb636c4 (diff)
Have osmo-bts request OML routes for all its MOs at startuplaforge/oml-router
During OML link start-up, osmo-bts now requests a OML route for each of the managed objects that it currently implements. This is done via the 'ORC' (OML Router Control) protocol, which is encapsulated in the extended IPA_PROTO_OSMO multiplex. The responses (ACK/NACK) are not yet processed inside osmo-bts.
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index c9173158..ff975162 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -7,10 +7,10 @@ libbts_a_SOURCES = gsm_data_shared.c sysinfo.c logging.c abis.c oml.c bts.c \
rsl.c vty.c paging.c measurement.c amr.c lchan.c \
load_indication.c pcu_sock.c handover.c msg_utils.c \
load_indication.c pcu_sock.c handover.c msg_utils.c \
- tx_power.c bts_ctrl_commands.c bts_ctrl_lookup.c
+ tx_power.c bts_ctrl_commands.c bts_ctrl_lookup.c \
+ oml_router_ctrl.c
bin_PROGRAMS = osmobts-omlrouter
osmobts_omlrouter_SOURCES = oml_router.c msg_utils.c oml_routing.c
osmobts_omlrouter_LDADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOVTY_LIBS) $(LIBOSMOABIS_LIBS) $(LIBOSMOGSM_LIBS)
-