aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2016-12-21 18:20:22 +0100
committerMax <msuraev@sysmocom.de>2016-12-22 15:11:05 +0100
commitc2ecca6b0496127709dcd3afa9d366085d8bec97 (patch)
treecef45df6e9a318956a4f8801d721a40670c410b6 /debian
parent86d78437127a05e4361ab171237e7d9b47325eda (diff)
Integrate Debian packaging changes
debian/control: * restructure to make it easier to incorporate further changes * update package descriptions * update project URL debian/rules: * use proper hardening syntax * restructure to make it easier to incorporate further changes * remove useless comment * add cleanup and test overrides debian/compat: update compatibility version Change-Id: Ibf62448eee1df914d21834f5b54831e3f642b79c Related: OS#1694
Diffstat (limited to 'debian')
-rw-r--r--debian/compat2
-rw-r--r--debian/control22
-rwxr-xr-xdebian/rules12
3 files changed, 29 insertions, 7 deletions
diff --git a/debian/compat b/debian/compat
index 7f8f011e..ec635144 100644
--- a/debian/compat
+++ b/debian/compat
@@ -1 +1 @@
-7
+9
diff --git a/debian/control b/debian/control
index d067e317..e1a58b28 100644
--- a/debian/control
+++ b/debian/control
@@ -1,12 +1,24 @@
Source: osmo-bts
+Maintainer: Holger Hans Peter Freyther <holger@moiji-mobile.com>
Section: net
Priority: optional
-Maintainer: Holger Hans Peter Freyther <holger@moiji-mobile.com>
-Build-Depends: debhelper (>= 7.0.0~), dh-autoreconf, dh-systemd (>= 1.5), autotools-dev, pkg-config, libosmocore-dev, libortp-dev, libosmo-abis-dev, libosmo-netif-dev
-Standards-Version: 3.8.4
-Homepage: http://osmocom.org/projects/osmobts
-Vcs-Git: git://git.osmocom.org/osmo-bts
+Build-Depends: debhelper (>= 9),
+ pkg-config,
+ dh-autoreconf,
+ dh-systemd (>= 1.5),
+ autotools-dev,
+ pkg-config,
+ libosmocore-dev,
+ openbsc-dev,
+ libosmo-abis-dev,
+ libosmo-netif-dev,
+ libgps-dev,
+ libortp-dev,
+ txt2man
+Standards-Version: 3.9.8
Vcs-Browser: http://git.osmocom.org/osmo-bts/
+Vcs-Git: git://git.osmocom.org/osmo-bts
+Homepage: https://projects.osmocom.org/projects/osmobts
Package: osmo-bts-trx
Architecture: any
diff --git a/debian/rules b/debian/rules
index f7f941b3..80ba0b2c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,7 +5,7 @@ DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
#export DH_VERBOSE=1
-export DEB_BUILD_HARDENING=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
%:
@@ -20,3 +20,13 @@ override_dh_autoreconf:
override_dh_auto_configure:
dh_auto_configure -- --enable-trx
+
+override_dh_clean:
+ dh_clean
+ $(RM) tests/package.m4
+ $(RM) tests/testsuite
+
+# Print test results in case of a failure
+override_dh_auto_test:
+ dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)
+