aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2016-04-01 16:46:42 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2016-04-01 17:01:54 +0200
commit460e1b7387ded53bd2ba320d3108196dc7100d40 (patch)
tree209fc698d2c277c6142484268bae920ea86d227a /debian/rules
parent21fc6e45fbe201dcc6c066a006cef899e931064a (diff)
debian: Create initial packaging for the osmo-bts-trx
This is only with osmo-bts-trx as others require headers that are not packaged yet.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..f7f941b3
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
+#export DH_VERBOSE=1
+export DEB_BUILD_HARDENING=1
+
+
+%:
+ dh $@ --with=systemd --with autoreconf --fail-missing
+
+override_dh_strip:
+ dh_strip --dbg-package=osmo-bts-trx-dbg
+
+override_dh_autoreconf:
+ echo $(VERSION) > .tarball-version
+ dh_autoreconf
+
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-trx