aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2017-10-08 17:56:33 +0200
committerMax <msuraev@sysmocom.de>2017-10-08 18:40:09 +0200
commitec33b0397f5d71248c5834513d4be7b9b0e46366 (patch)
treea0f132d846759d742243c13f8647364caf8079ea /configure.ac
parent8a89c7d3c327c3594c8dc6251179c0e66b1ba3e5 (diff)
Remove build dependency on legacy OpenBSC
* copy-paste gsm_data_shared.* from OpenBSC master * remove corresponding configure check and option * remove .deb dependency Actual refactoring with removal of unnecessary structures/parts, moving common OpenBSC/OsmoBSC parts into libraries etc. are left for further patches. Current patch will make coexistence with *BSC easier and will simplify our build infrastructure. Change-Id: I9f004fb5c4c1db29d4792dfd281d388c7063da13 Related: OS#1923
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 1 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index bc36456f..a41f7eca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -147,25 +147,9 @@ if test "$enable_litecell15" = "yes"; then
CPPFLAGS=$oldCPPFLAGS
fi
-# We share gsm_data.h with OpenBSC and need to be pointed to the source
-# directory of OpenBSC for now.
-AC_ARG_WITH([openbsc],
- [AS_HELP_STRING([--with-openbsc=INCLUDE_DIR],
- [OpenBSC include directory for openbsc/gsm_data_shared.h])],
- [openbsc_incdir="$withval"],
- [openbsc_incdir="`cd $srcdir; pwd`/../openbsc/openbsc/include"])
-AC_SUBST([OPENBSC_INCDIR], $openbsc_incdir)
-
-oldCPPFLAGS=$CPPFLAGS
-CPPFLAGS="$CPPFLAGS -I$OPENBSC_INCDIR -I$srcdir/include $LIBOSMOCORE_CFLAGS"
-AC_CHECK_HEADER([openbsc/gsm_data_shared.h],[],
- [AC_MSG_ERROR([openbsc/gsm_data_shared.h can not be found in $openbsc_incdir])],
- [#include <osmo-bts/tx_power.h>])
-CPPFLAGS=$oldCPPFLAGS
-
# Check for the sbts2050_header.h that was added after the 3.6 release
oldCPPFLAGS=$CPPFLAGS
-CPPFLAGS="$CPPFLAGS -I$OPENBSC_INCDIR $LIBOSMOCORE_CFLAGS"
+CPPFLAGS="$CPPFLAGS $LIBOSMOCORE_CFLAGS"
AC_CHECK_HEADER([sysmocom/femtobts/sbts2050_header.h],
[sysmo_uc_header="yes"],[])
CPPFLAGS=$oldCPPFLAGS